Smartsheet Logo
Intermittent Issues
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Apr 08, 2020 - 12:26 PDT
Update
We are continuing to monitor for any further issues.
Posted Apr 07, 2020 - 19:27 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability.
Posted Apr 07, 2020 - 12:44 PDT
Update
We are continuing to investigate the issue with the Smartsheet platform including Forms, Reporting, and Automation Rules. We will provide an update within the next 30 minutes.
Posted Apr 07, 2020 - 12:36 PDT
Investigating
We are investigating issues with the Smartsheet platform. We will provide an update within the next 30 minutes.
Posted Apr 07, 2020 - 12:05 PDT
This incident affected: Core Application (Sheets).