Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet Intermittent Connectivity
Incident Report for Smartsheet
Postmortem

On December 4th, 2023 at 13:26 PT, a Sheetlink database deployment encountered an error that led to a 4 minute site-wide outage where users were unable to access workflows. Our engineers were able to roll back the deployment and service was fully recovered by 13:29:30 PT.

Posted Dec 04, 2023 - 15:39 PST

Resolved
This incident has been resolved.
Posted Dec 04, 2023 - 15:38 PST
Monitoring
We've received customer reports of Smartsheet intermittent connectivity. A fix has been implemented and we are monitoring to ensure continued stability of the service.
Posted Dec 04, 2023 - 13:39 PST