Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Some Sheets Unable to Save
Incident Report for Smartsheet
Postmortem

On September 17th, 2022 at 3:30 PDT, some customers were unable to save their sheets. On September 19th, 2022 8:00pm PST, our engineers were able to restore save sheet functionality back to normal. Some impacted sheets are not showing complete cell history. All history is safe and we are actively working on restoring cell history in the UI.

Posted Sep 26, 2022 - 09:52 PDT

Resolved
This incident has been resolved.
Posted Sep 19, 2022 - 21:48 PDT
Monitoring
A small subset of sheets were unable to save and now these services are back up and running normally. Some sheets will not see complete cell history. All the history is still safe and we are actively working on restoring the history. Please contact customer support if you need access to cell history data urgently on a specific impacted sheet.
Posted Sep 19, 2022 - 19:48 PDT
Update
We are working on several mitigation paths.
Posted Sep 19, 2022 - 18:53 PDT
Update
We are working on several mitigation paths.
Posted Sep 19, 2022 - 17:44 PDT
Update
The issue has been identified and we are working on a fix.
Posted Sep 19, 2022 - 16:36 PDT
Update
The issue has been identified and we are working on a fix.
Posted Sep 19, 2022 - 15:37 PDT
Identified
The issue has been identified and we are working on a fix.
Posted Sep 19, 2022 - 14:32 PDT
Investigating
We are continuing to investigate some customer reports of some sheets unable to save. We’ll continue providing updates every 30 minutes and will send another notification to subscribers with the next functional update.
Posted Sep 19, 2022 - 14:02 PDT
This incident affected: Core Application (Sheets).