Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 

Smartsheet App Unavailable

Incident Report for Smartsheet

Postmortem

On August 8th, 2025, starting at 5:15 PM PST, users began experiencing errors and difficulties accessing Smartsheet. By 5:56 PM PST, full service was confirmed to be restored for all users.

Our engineering teams quickly determined that a recent internal service deployment was the cause of Smartsheet's unavailability.

A rollback of this deployment was initiated, and full service was restored by approximately 5:56 PM PST. We are currently reviewing our deployment processes and internal service dependencies to prevent similar issues in the future.

Posted Aug 25, 2025 - 20:06 PDT

Resolved

This incident has been resolved.
Posted Aug 25, 2025 - 20:01 PDT

Monitoring

A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Aug 25, 2025 - 18:05 PDT

Identified

We have identified the issue and taken action to resolve. The service is recovering and we will continue to monitor. We will continue to provide frequent updates as we work towards resolution.
Posted Aug 25, 2025 - 17:50 PDT

Investigating

We are currently investigating some customer reports of the Smartsheet application not loading for users. We will continue to provide frequent updates as we work towards resolution.
Posted Aug 25, 2025 - 17:34 PDT
This incident affected: Core Application (Smartsheet Login, Sheets, Forms, Reports, Dashboards).