Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Some users are unable to load some sheets
Incident Report for Smartsheet
Postmortem

On November 15, 2022 from approximately 7AM to 9:30AM PST, we received reports that some customers were sometimes unable to load certain sheets. We implemented a fix at around 9:30AM, which resolved the issue.

Posted Nov 15, 2022 - 10:44 PST

Resolved
This incident has been resolved.
Posted Nov 15, 2022 - 10:23 PST
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Nov 15, 2022 - 09:36 PST
Investigating
We are currently investigating customer reports of some sheets not loading consistently. We will provide an update in 60 minutes.
Posted Nov 15, 2022 - 08:11 PST
This incident affected: Core Application (Sheets, Reports).