Smartsheet Logo
Cell Link delays
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jul 09, 2020 - 22:00 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Jul 08, 2020 - 21:50 PDT
Update
We are continuing to investigate and will provide an update when one becomes available.
Posted Jul 08, 2020 - 18:59 PDT
Update
We are continuing to investigate and will provide an update within the next 30 minutes.
Posted Jul 08, 2020 - 18:27 PDT
Investigating
Our monitoring systems have detected a delay in cell link updates. Outgoing cell links may be delayed if that cell contains a formula that calculates data submitted by a form. We are investigating and will provide an update within the next 30 minutes.
Posted Jul 08, 2020 - 17:55 PDT