Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Report Delays
Incident Report for Smartsheet
Resolved
The report functionality within Smartsheet is now up to date. Our monitoring period for this issue has ended and no further impact has been observed.
Posted Mar 22, 2018 - 11:57 PDT
Monitoring
We have made an update to the report processing engine that has had a positive impact on the latency issues. Reports are now current and the engineering team is monitoring closely.
Posted Mar 21, 2018 - 10:44 PDT
Identified
The engineering team at Smartsheet is aware of the delays associated with our reporting platform during peak morning hours. We are investigating the root cause and testing potential solutions. We will provide an update when we have a firm estimate on a full recovery.
Posted Mar 20, 2018 - 22:00 PDT
Update
We are currently experiencing delays in reporting. We are investigating the issue.
Posted Mar 19, 2018 - 09:52 PDT
Investigating
We're currently experiencing some delay issues with Reports in Smartsheet. We are aware of the issue and are working to get it fixed right away. Thanks for your patience.
Posted Mar 14, 2018 - 08:16 PDT
This incident affected: Core Application (Reports).