Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Intermittent Connection Issues
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted May 02, 2022 - 13:32 PDT
Monitoring
We received a few customer reports of intermittent errors when accessing Smartsheet. A fix has been implemented and we are monitoring for stability.
Posted May 02, 2022 - 10:50 PDT
This incident affected: Core Application (Sheets, Reports, Dashboards).