Smartsheet Logo
Latency in Smartsheet App & Forms
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jul 23, 2020 - 11:42 PDT
Monitoring
Smartsheet experienced a temporary issue which impacted some loading and saving of Smartsheet items. A fix has been implemented and we are monitoring to ensure continued stability of the Smartsheet application.
Posted Jul 22, 2020 - 11:25 PDT
This incident affected: Core Application (Sheets, Reports).