Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Loading and Saving
Incident Report for Smartsheet
Resolved
The Smartsheet Application has remained stable since our engineers took action to mitigate the issue. The issue has been resolved, and we are closing this incident
Posted Oct 19, 2018 - 22:00 PDT
Monitoring
Saving and loading of sheets, reports, and dashboards has returned to normal. We will continue to monitor this issue to ensure platform stability.
Posted Oct 18, 2018 - 20:55 PDT
Investigating
We have seen the issue from the previous evening return and are working to restore the system.
Some users may see issues with loading and saving data.
Posted Oct 18, 2018 - 20:46 PDT
Monitoring
Saving and loading of sheets, reports, and dashboards has returned to normal. We will continue to monitor this issue.
Posted Oct 17, 2018 - 21:59 PDT
Investigating
Some customers my experience latency with loading and saving some sheets, reports, and dashboards. We are currently working to resolve the issue.
Posted Oct 17, 2018 - 21:34 PDT
This incident affected: Core Application (Sheets) and Developers and API (REST API).