Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Intermittent Connectivity
Incident Report for Smartsheet
Postmortem

On February 17th from 15:05 PST to 16:00 PST,  some Smartsheet users that tried to access Sheets, Reports and Dashboard were intermittently not able to do so. This was a result of improper error handling configuration by our system during a period of degraded service with our Content Delivery Network, Amazon Web Services (AWS) CloudFront.  The issue was resolved when AWS restored services for our systems.

 To mitigate potential future issues with our CDN, we have improved our error handling and implemented additional caching so that customers can continue to access their assets in the event of a failure. At Smartsheet we are committed to investing in our infrastructure to minimize impacts to all of our customers.

 While we cannot promise a future free of any technical challenges, we promise that we will do whatever it takes to ensure that Smartsheet is a partner that can be counted on to deliver. We know that your success—and your continued trust in Smartsheet—depends on it.

Posted Feb 18, 2022 - 09:35 PST

Resolved
This incident has been resolved.
Posted Feb 17, 2022 - 19:27 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2022 - 16:53 PST
Update
We are currently investigating some customer reports of intermittent Smartsheet app connectivity. We’ll continue providing updates every 60 minutes. Our mobile app on iOS/Android is unaffected.
Posted Feb 17, 2022 - 15:50 PST
Investigating
We are currently investigating some customer reports of intermittent Smartsheet app connectivity. We’ll continue providing updates every 30 minutes and will send another notification to subscribers with the next functional update.
Posted Feb 17, 2022 - 15:20 PST
This incident affected: Core Application (Sheets, Reports, Dashboards).