Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Loading and saving sheets
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted May 07, 2020 - 16:00 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of the service.
Posted May 06, 2020 - 16:01 PDT
Identified
We have identified the issue and taken action to resolve. The service is recovering and we will continue to monitor.
Posted May 06, 2020 - 15:48 PDT
Investigating
We are investigating reports of customers experiencing issues accessing some sheets, reports, or dashboards. We will provide an update within the next 30 minutes.
Posted May 06, 2020 - 15:33 PDT
This incident affected: Core Application (Sheets) and Developers and API (REST API).