Smartsheet Logo
Email Delays and Form Submissions
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jan 14, 2020 - 07:35 PST
Monitoring
A fix has been implemented for the issue and we'll continue to monitor.
Posted Jan 13, 2020 - 07:53 PST
Investigating
We are currently investigating an issue impacting emails, notifications, and the submission of forms when email confirmation is enabled. We will provide an update within the next 30 minutes.
Posted Jan 13, 2020 - 07:30 PST
This incident affected: System Generated Emails.