Smartsheet Logo
Smartsheet Intermittently Unavailable (resolved)
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Aug 12, 2020 - 13:03 PDT
Update
We are continuing to monitor for any further issues.
Posted Aug 11, 2020 - 20:43 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure the continued stability of the Smartsheet application.
Posted Aug 11, 2020 - 12:54 PDT
Investigating
We are investigating customer reports of errors in Smartsheet and will provide an update within the next 30 minutes.
Posted Aug 11, 2020 - 12:27 PDT
This incident affected: Core Application (Sheets, Reports, Dashboards).