Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 

Smartsheet intermittent errors

Incident Report for Smartsheet

Postmortem

On May 7th, starting around 6:50 AM PDT, some users experienced unexpected issues loading sheets and dashboards, executing workflows, and submitting forms (including update and approval requests). Our Engineering teams quickly identified that a recent internal service deployment caused degraded performance for these features. A fix was implemented and service was fully restored by 9:00 AM PDT.

Posted May 07, 2025 - 14:14 PDT

Resolved

This incident has been resolved.
Posted May 07, 2025 - 11:17 PDT

Monitoring

We have identified the issue and have implemented a fix. We are monitoring to ensure continued stability of these features.
Posted May 07, 2025 - 09:08 PDT

Update

We are continuing to investigate this issue.
Posted May 07, 2025 - 08:03 PDT

Investigating

We are investigating some reports of intermittent errors in workflow execution, in loading dashboards and sheets, and in loading and submitting forms (including update and approval requests). We will update this status message as our investigation progresses.
Posted May 07, 2025 - 07:50 PDT
This incident affected: Workflows (In App Workflows) and Core Application (Sheets, Forms, Dashboards).