Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet down when logging in
Incident Report for Smartsheet
Postmortem

A brief service disruption occurred at Smartsheet on September 4th, 2024, impacting some users' ability to log in. The issue began at 6:16 AM PT and was resolved by 6:50 AM PT on the same day. The disruption was attributed to a recent change in the login infrastructure, which necessitated further load flexibility adjustments. To quickly restore service, the change was rolled back.
While not all deployments and service releases are communicated to customers, Smartsheet acknowledges the delay in posting about the outage and pledges to ensure timely communication about similar incidents in the future.

Posted Sep 12, 2024 - 14:03 PDT

Resolved
This incident has been resolved.
Posted Sep 04, 2024 - 06:50 PDT