Smartsheet Logo
Intermittent Issues
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Feb 27, 2020 - 10:40 PST
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of Smartsheet.
Posted Feb 26, 2020 - 10:27 PST
Investigating
We are investigating issues with the Smartsheet platform. We will provide an update within the next 30 minutes.
Posted Feb 26, 2020 - 10:19 PST
This incident affected: Core Application (Sheets).