Smartsheet Logo
Smartsheet is temporarily unavailable
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Nov 16, 2019 - 23:59 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2019 - 23:03 PST
Investigating
Smartsheet will be temporarily unavailable for maintenance. We will update when it is completed.
Posted Nov 16, 2019 - 22:36 PST
This incident affected: Smartsheet Application (Mobile/API, Web Application).