Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 

Failures during Form Submissions

Incident Report for Smartsheet

Postmortem

On Monday, April 13, between 7:00 AM and 11:30 AM PST, some users experienced failures when submitting Smartsheet forms. The issue was isolated to CAPTCHA-enabled forms and was caused by a problem with our reCAPTCHA verification endpoint. Error rates declined significantly by mid-morning and the incident was fully resolved by 11:30 AM PST. All form submissions are operating normally.

Posted Apr 14, 2026 - 07:27 PDT

Resolved

Forms Submissions are operating normally. The incident is now resolved.
Posted Apr 13, 2026 - 13:46 PDT

Monitoring

The issue has been identified, Form submissions are operating normally now. Our team will continue to monitor the service and implement the necessary changes to prevent recurrence.
Posted Apr 13, 2026 - 11:31 PDT

Update

We are continuing to investigate this issue.
Posted Apr 13, 2026 - 10:52 PDT

Update

We are continuing to investigate this issue.
Posted Apr 13, 2026 - 10:06 PDT

Investigating

We are currently investigating an issue affecting Smartsheet Forms where a subset of users are experiencing failures when submitting forms.
Posted Apr 13, 2026 - 09:33 PDT
This incident affected: Core Application (Forms).