Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Errors creating sheets and reports
Incident Report for Smartsheet
Postmortem

At 7:08pm PDT on July 18th, 2024 we observed errors when users created or copied sheets and reports. The team identified the issue and applied a fix. Service was restored to normal operation at 7:40pm PDT on July 18th, 2024.

Posted Jul 18, 2024 - 21:57 PDT

Resolved
This incident has been resolved.
Posted Jul 18, 2024 - 21:57 PDT
Monitoring
We received some customer reports of errors while creating and copying sheets and reports. A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Jul 18, 2024 - 19:57 PDT
This incident affected: Core Application (Sheets, Reports).