Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
We are aware there is a service incident and are investigating the issue
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted May 31, 2018 - 19:15 PDT
Update
We have determined that this workspace creation issue is limited to an isolated group of users and is not a systemic failure. We will be working directly with the affected organization to resolve the issue.
Posted May 31, 2018 - 12:43 PDT
Investigating
Our monitoring system has identified a potential service interruption with workspace creation. We are currently investigating the issue and will provide an update as soon as possible. Please continue to return to this page for the latest resolution status.
Posted May 31, 2018 - 12:39 PDT
This incident affected: Core Application (Sheets) and Developers and API (REST API).