Smartsheet Logo
General Email Deliverability delays
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jan 07, 2021 - 16:16 PST
Monitoring
Email service has been restored. We are monitoring and working with our service provider to ensure the continued stability of this feature.
Customers may have noticed app-generated email delays of up to an hour.
Posted Jan 07, 2021 - 14:12 PST
Investigating
Our monitoring systems have detected email delivery delays of app-generated emails such as those generated from automation rules, sheets sent as an attachment, or password resets. In-app and mobile push notifications are fully functional.
We are investigating and will provide an update within the next 30 minutes.
Posted Jan 07, 2021 - 13:46 PST
This incident affected: Notifications (Email Notifications, In App Notifications, Messaging App Notifications).