Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Search Latency
Incident Report for Smartsheet
Resolved
The search functionality within Smartsheet is now up to date. The delay issue has ended and no further impact has been observed.
Posted Jun 21, 2018 - 13:48 PDT
Investigating
We're currently experiencing some delay issues with the search functionality in Smartsheet. We're aware of the issue and are working to get it fixed right away. Thanks for your patience.
Posted Jun 21, 2018 - 13:25 PDT
This incident affected: Core Application (Search).