This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.
Get email notifications whenever Smartsheet creates, updates or resolves an incident.
Get text message notifications whenever Smartsheet creates, updates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
We experienced intermittent delays in loading the app between 1:35 PM and 2:25 PM PDT on August 1st due to an issue identified during an app update. The update was rolled back, and all systems are now fully operational.
Posted Aug 01, 2024 - 16:35 PDT
Resolved
This incident has been resolved.
Posted Aug 01, 2024 - 16:29 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 01, 2024 - 14:27 PDT
Investigating
Some customers may experience latency with loading and saving some sheets, reports, and dashboards. We are currently working to resolve the issue.
Posted Aug 01, 2024 - 14:12 PDT
This incident affected: Core Application (Sheets, Forms, Reports, Dashboards).