Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet App Connectivity
Incident Report for Smartsheet
Postmortem

Between 12:07 PM PDT and 1:30 PM PDT on April 2, 2024, some customers experienced errors or delays in accessing sheets, reports and dashboards. We identified a capacity issue within the Authentication service, and scaled to eliminate delays and restore normal service operations.

Posted Apr 03, 2024 - 15:31 PDT

Resolved
This incident has been resolved.
Posted Apr 02, 2024 - 16:16 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure stability of the service.
Posted Apr 02, 2024 - 14:14 PDT
Update
We are currently investigating reports of intermittent Smartsheet app connectivity. We will provide an update within 30 minutes.
Posted Apr 02, 2024 - 13:48 PDT
Investigating
We are currently investigating reports of intermittent Smartsheet app connectivity issues. We will provide an update within 30 minutes.
Posted Apr 02, 2024 - 13:17 PDT
This incident affected: Core Application (Sheets, Reports, Dashboards).