Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Bridge Workflow Delays
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Nov 20, 2020 - 04:29 PST
Monitoring
We identified delays in Bridge workflows triggering. Our team has taken steps to resolve this and workflows are now processing normally. We are monitoring to ensure the continued stability of this feature.
Posted Nov 20, 2020 - 02:29 PST
This incident affected: Workflows (Bridge by Smartsheet).