Smartsheet Logo
Smartsheet Control Center Unavailable
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted 21 days ago. Aug 30, 2019 - 22:17 PDT
Monitoring
Smartsheet Control Center is now operating normally. A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted 22 days ago. Aug 30, 2019 - 13:26 PDT
Update
Smartsheet Control Center is currently offline as we address reports from some customers that Global Updates are not performing as expected. We expect the service to return to normal operation by 2pm PDT.
Posted 22 days ago. Aug 30, 2019 - 13:06 PDT
Update
The Smartsheet Control Center application is temporarily unavailable. It was taken offline to address some customer reports of global updates not operating as expected.
Posted 22 days ago. Aug 30, 2019 - 12:31 PDT
Investigating
We are investigating an issue with the Smartsheet Control Center application and will provide an update as soon as possible.
Posted 22 days ago. Aug 30, 2019 - 12:21 PDT