Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 

Smartsheet App Slow Performance

Incident Report for Smartsheet

Postmortem

At 7:59 AM PDT on August 5th, 2024, Smartsheet began investigating customer reports of slow performance. We discovered the source of the issue was related to a recent change that forced users to download a large file when loading Smartsheet. At 10:50 AM PDT, a fix was rolled out to mitigate the issue.

Posted 8 months ago. Aug 06, 2024 - 07:42 PDT

Resolved

This incident has been resolved.
Posted 8 months ago. Aug 05, 2024 - 15:46 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 8 months ago. Aug 05, 2024 - 12:18 PDT

Identified

We have identified the issue and are taking actions to resolve.
Posted 8 months ago. Aug 05, 2024 - 09:08 PDT

Investigating

We are currently investigating reports of slow performance in the Smartsheet App. We will provide an update in 60 minutes.
Posted 8 months ago. Aug 05, 2024 - 08:27 PDT
This incident affected: Core Application (Sheets, Reports, Dashboards).