Smartsheet Logo
App-generated email delays
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Sep 18, 2019 - 16:11 PDT
Investigating
Our monitoring systems have detected email delivery delays of app-generated emails such as those generated from automation rules, sheets sent as an attachment, Update and Approval requests.
We are investigating and will provide an update within the next 30 minutes.
Posted Sep 18, 2019 - 16:06 PDT
This incident affected: System Generated Emails.