This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.
Get email notifications whenever Smartsheet creates, updates or resolves an incident.
Get text message notifications whenever Smartsheet creates, updates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
On October 1st, 2024, at 9:30 AM PT, we began investigating reports of users experiencing access errors when uploading new assets or new versions of assets. We identified the cause within our partner service and implemented a mitigation which allowed uploads to resume successfully. Service was fully restored on October 10th, 2024 at 2:00pm PT.
Posted Oct 10, 2024 - 16:19 PDT
Resolved
This incident has been resolved.
Posted Oct 10, 2024 - 16:19 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Oct 10, 2024 - 14:18 PDT
Update
We are investigating intermittent temporary access issues primarily after users upload new asset versions and some new assets. This issue typically resolves itself within half an hour of the upload. We are continuing to work with our partner service to resolve this issue.
Posted Oct 03, 2024 - 16:09 PDT
Investigating
We have identified that some users are intermittently unable to access assets once uploaded. This issue typically resolves itself within a few minutes. We are working with our partner service to resolve the issue.
Posted Oct 02, 2024 - 10:49 PDT
This incident affected: Digital Asset Management (Brandfolder) (Asset Upload).