Smartsheet Logo

Smartsheet Status

 
Application Latency
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Sep 07, 2021 - 08:30 PDT
Monitoring
We received a number of customer reports of latency in the Smartsheet application. A fix was quickly identified and implemented and we are monitoring to ensure continued stability of the service.
Posted Sep 07, 2021 - 06:26 PDT
This incident affected: Administration and Audit (Admin Center), Core Application (Sheets, Forms, Reports), and Authentication and Sign In (Smartsheet Login).