Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Dynamic View Latency
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jan 20, 2021 - 12:36 PST
Monitoring
A fix has been implemented and we are monitoring to ensure the continued stability of the Dynamic View service.
Posted Jan 20, 2021 - 10:36 PST
Update
We are currently investigating customer reports of slow loading of Dynamic Views. We will provide an update in 30 minutes.
Posted Jan 20, 2021 - 09:58 PST
Investigating
We are currently investigating customer reports of slow loading of Dynamic Views. We will provide an update in 30 minutes.
Posted Jan 20, 2021 - 09:27 PST
This incident affected: Premium Apps (Dynamic View).