Smartsheet Logo
Intermittent Sheet Load Failures
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jul 04, 2020 - 05:01 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of the Smartsheet service.
Posted Jul 03, 2020 - 03:17 PDT
Identified
We have identified an issue where customers are getting intermittent failures loading sheets and are working to resolve it. We will provide an update within the next 30 minutes.
Posted Jul 03, 2020 - 02:52 PDT
This incident affected: Core Application (Sheets).