Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Slow Forms Performance
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jun 21, 2019 - 01:35 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Jun 20, 2019 - 11:15 PDT
Identified
The cause of this issue has been identified and a fix is being implemented.
Posted Jun 20, 2019 - 10:35 PDT
Update
We're continuing to investigate and will provide another update in 30 minutes.
Posted Jun 20, 2019 - 10:33 PDT
Update
We're continuing to investigate and will provide another update in 30 minutes.
Posted Jun 20, 2019 - 10:02 PDT
Update
We're continuing to investigate and will provide another update in 30 minutes.
Posted Jun 20, 2019 - 09:33 PDT
Investigating
We are investigating slow form submissions, and issues with forms rendering for some users. We will provide an update within the next 30 minutes.
Posted Jun 20, 2019 - 08:59 PDT
This incident affected: Core Application (Sheets).