Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Connectors Websites Inaccessible
Incident Report for Smartsheet
Postmortem

On March 28th, 2021 at 4:22pm PDT, the Connectors service experienced a slow down which caused a build of traffic. This made it difficult to log in to the connectors website (https://connectors.smartsheet.com/) and caused delays to processing workflows. After investigation, capacity was increased and the service was restored to full operation by 6:42pm PDT. We are continuing to monitor the service and will make improvements based on our learnings to avoid similar incidents in the future.

Posted Mar 29, 2021 - 09:57 PDT

Resolved
This incident has been resolved.
Posted Mar 28, 2021 - 20:53 PDT
Monitoring
A fix has been implemented and the service is operating normally. We are monitoring to ensure continued stability of this feature.
Posted Mar 28, 2021 - 18:53 PDT
Update
We are continuing to investigate slowness when accessing https://connectors.smartsheet.com/. There may be delays in workflow execution. We will provide an update in 30 minutes.
Posted Mar 28, 2021 - 18:19 PDT
Update
We are continuing to investigate inability to log in to https://connectors.smartsheet.com/. There may be delays in workflow execution. We will provide an update in 30 minutes.
Posted Mar 28, 2021 - 17:47 PDT
Update
We are continuing to investigate inability to log in to https://connectors.smartsheet.com/. We will provide an update in 30 minutes.
Posted Mar 28, 2021 - 17:14 PDT
Investigating
We are currently investigating inability to log in to https://connectors.smartsheet.com/ to manage Connectors. We will provide an update in 30 minutes.
Posted Mar 28, 2021 - 16:44 PDT
This incident affected: Connectors (Dynamics Connector, Jira Connector, Salesforce Connector).