Smartsheet Logo
App-generated email delays
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Nov 25, 2020 - 16:06 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2020 - 14:06 PST
Identified
Our team has identified the cause of the email delivery delays of app-generated emails and are working to resolve it. We will provide additional updates as they become available.
Posted Nov 25, 2020 - 11:43 PST
Investigating
Our monitoring systems have detected email delivery delays of app-generated emails such as those generated from automation rules, sheets sent as an attachment, or password resets.
We are investigating and will provide an update within the next 30 minutes.
Posted Nov 25, 2020 - 11:06 PST
This incident affected: Notifications (Email Notifications).