Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet Intermittently Unavailable
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted May 06, 2020 - 09:46 PDT
Monitoring
A fix has been implemented for the intermittent availability and we are monitoring to ensure continued stability of Smartsheet.
Posted May 05, 2020 - 09:44 PDT
Identified
We have identified the cause of the intermittent availability and a fix is being implemented.
Posted May 05, 2020 - 09:32 PDT
Investigating
We are investigating reports of intermittently availability of Smartsheet and will provide an update within the next 30 minutes or as status changes.
Posted May 05, 2020 - 09:06 PDT
This incident affected: Core Application (Sheets).