Smartsheet Logo
General Application Latency
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 18, 2019 - 10:50 PDT
Identified
The cause of this issue with Reporting has been identified and a fix is being implemented. Issues with Automation and Notifications are continuing to be investigated.
Posted about 1 month ago. Jul 18, 2019 - 09:51 PDT
Update
We are continuing to investigate this issue. You may experience delays or errors with Reports, Dashboards, configuring Automation rules, and when accessing Notifications. We will provide an update in the next 30 minutes.
Posted about 1 month ago. Jul 18, 2019 - 09:12 PDT
Investigating
We are investigating general latency with Smartsheet. We will provide an update in the next 30 minutes.
Posted about 1 month ago. Jul 18, 2019 - 08:41 PDT
This incident affected: Smartsheet Application (Mobile/API, Web Application) and Reporting.