Smartsheet Logo

Smartsheet Status

 
 
Unable to access Admin Center
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Sep 21, 2021 - 16:00 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 21, 2021 - 14:01 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 21, 2021 - 13:12 PDT
Investigating
We are currently investigating some customer reports of not being able to access Admin Center. We will provide an update in 30 minutes.
Posted Sep 21, 2021 - 12:42 PDT
This incident affected: Administration and Audit (Admin Center).